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Overview
MAPI Message Pad is a telephone message system that supplements or replaces the 
traditional "While You Were Out" message pad.    

Message Pad utilizes the messaging services (MAPI) provided by Windows for Workgroups 
and Microsoft Mail 3.0.    It requires a post office and user accounts created with either 
Microsoft Mail 3.x or the Mail application provided with Windows for Workgroups.    Because 
of its ability to access the accounts on your existing Mail system, Message Pad is very easy 
to install, use and maintain.    

Message Pad is tightly integrated with MS Mail.    Messages sent with Message Pad appear 
in the MS Mail Inbox and can be viewed in either MS Mail or Message Pad.    One advantage 
of this close integration is that you do not need to run Message Pad all of the time in order 
to be notified of new Message Pad messages.    If MS Mail is running, it will trigger a dialog 
box which will notify you that you have received a new phone message.

Message Pad is Shareware.    You can try it for free for 30 days.    If you continue to use it, 
you must purchase it.    Message Pad is reasonably priced to provide value and to 
encourage registration.    



Sending Messages
To send a message 

Click the "Compose" button or choose "Compose Message" from the File menu.    This 
clears Message pad and enters the current date and time.      You can also create a new 
message by clicking the rolodex button next to the "To" box.    This will let you select the 
recipient from your address book.

Enter the name of the recipient of the message in the "To" box    or use the recipient 
pick list.    You can enter a partial name and click the checkmark button to verify and fill in 
the rest of the name.

Enter the name and phone number of the caller and other pertinent information.    
Press TAB to move the insertion point to the next box.    Press SHIFT-TAB to move to the previous
textbox.

Click the "Send" button or choose "Send Message" from the File menu.
When you Send a message, Message Pad checks to see if the recipient is a valid Mail 
account.    If you enter a partial name, for instance the first name only, Message Pad will 
attempt to match that name with an existing account.    If the partial name matches more 
than one account, you will be given the opportunity to select from among the matching 
names.



Recipient Pick List
Message Pad lets you create a pick list of people you frequently send messages to.    Names
can be selected from the pick list by clicking the down arrow button next to the "To" box or 
by pressing the Down Arrow key on your keyboard when the cursor is in the "To" box.

The pick list is also used to autofill the "To" box.    As you type the recipient's name, 
Message Pad will check for matching names in the pick list and will automatically fill in the 
rest of the name for you.

To modify the pick list, select "Recipient Pick List" from the "Options" menu.    This will 
display the "Recipient List" dialog box, which allows you to add or remove names from the 
recipient pick list.    You can add names directly from your Mail Address Book by clicking the 
Address Book button in the "Recipient List" dialog.

The recipient pick list is maintained in a text file named RECIPS.LST in your Message Pad 
directory.



Working With Messages You've Received
Message Pad checks your Mail account for new phone messages at the time interval 
specified in the Preferences Dialog.    You can also direct Message Pad to check for new 
messages by clicking the "Get New" button.

When new messages are received, they are displayed in the Pending Messages listbox with 
the following markers:

Messages that have not been read

Messages that have been read

Urgent messages

You can perform the following actions on received messages:
Display the message
Print the message
Forward the message to another person
Delete the message from the Pending Messages listbox
Save changes to the message
Record Followup activities



Displaying Messages
To display a message shown in the Pending Messages listbox 

Select the message in the listbox using the arrow keys or single-click on the message
with the mouse 



Printing a Message
To print a message

Display the message in the message pad
Click the "Print" button or choose "Print Message" from the File menu.

If your printer is capable of printing True Type fonts, the message will be printed with the 
Arial font.    Otherwise, it will be printed using the default font on your printer.



Deleting a Message
To delete a message

Select the message in the "Pending Messages" listbox.
Click the "Delete" button or choose "Delete Message" from the File menu.

Deleting a message also clears the message pad.



Forwarding a message
Any message that you have received can be forwarded to another user.    

To forward a message

Display the message in the message pad
Click the "Forward" button.
Enter the mailbox name of the person to receive the message in the displayed dialog 

box.    When you click OK, the message will be sent.
Before sending the message, Message Pad adds the text "Message Forwarded by 

[Your Name]" to the Note box.    It adds the text "Message Forwarded to [New Recipients 
Name]" to your copy of the message.
You may alter the contents of the message before forwarding it.



Setting Message Pad Preferences
Message preferences and the default Action settings can be changed in the Preferences 
dialog box.    The Preferences dialog box is displayed by selecting "Preferences" from the 
Options menu.

Default Action settings
The default action settings are the message checkboxes that are automatically checked 
when you select Compose from the toolbar or the File menu.    The default Action settings 
can be changed in the Preferences dialog by selecting new actions and clicking OK.

New Message settings
In the "Check for new messages" box, type how often you want Message Pad to look 

for new phone messages.
If you want Message Pad to beep when you receive a new phone message, select the 

"Sound chime" check box.
If you want Message Pad to display a popup dialog when you receive a new phone 

message, select the "Popup" check box.
Other preferences

Launch Message Pad when message opened in MS Mail
Message Pad phone messages are listed in Microsoft Mails Inbox.    If you want phone 
messages to be displayed by Message Pad when they are opened in MS Mail, select this 
checkbox.    If this box is not checked, phone messages will be displayed in Mail like any 
other message.    This setting applies to all messages in Mail folders.

Clear Message Pad when Address Book is used

If this box is checked, the message pad is cleared and the time and date are reset when a 
name is selected from the Address Book.



Installation
In an effort to keep the number of files required for downloading to a minimum, the Setup 
program assumes that VBRUN300.DLL is already installed in your Windows\System 
directory.    If you do not have VBRUN300.DLL it can be obtained in section 5 of the MSBasic 
forum or section 12 of the MSWRKGRP forum on CompuServe.

IMPORTANT:Neither the Setup program nor Message Pad will run unless VBRUN300.DLL is 
installed in your Windows or Windows\System directory.

To install Message Pad using the Setup program

From the Windows Program Managers File menu, choose Run

In the Command Line box, type X:\SourcePath\Setup, where X:\SourcePath is the 
drive and directory where the Message Pad files are located. 
To manually install Message Pad

Create a new directory for the Message Pad application files (e.g. c:\msgpad)

Copy MSGPAD.EXE, REGISTER.WRI, README.TXT, MANUAL.WRI, MSGPAD.HLP and 
UNINSTAL.TXT to the new directory 

Copy MHIT200.VBX, APPEXEC.DLL and VBRUN300.DLL to your Windows\System 
directory

Add the following line to the [Custom Messages] section of MSMAIL.INI:
IPM.BDSMessagePad.MPNotify=3.0;Mail;&Message Pad;13;APPEXEC.DLL;C:\MSGPAD\
MSGPAD.EXE <PARAMBLK>;1122222100000000;;;;

Create a Program Manager item with the command line set to c:\msgpad\msgpad.exe
(or to whatever path you copied msgpad.exe and msgpad.hlp)
You also must have a post office and user accounts created with MS Mail.    You do not need 
to set up any additional accounts or tell Message Pad who you are.    When you start up 
Message Pad, it will automatically log on to your regular MS Mail account.



Ordering Message Pad
Message Pad is shareware. You are licensed to use this software for 30 days without charge.
If you continue to use it , you must purchase it.

Orders for Message Pad can be placed by completing the Order form (ORDER.WRI) in your 
MSGPAD directory and mailing it with payment or purchase order to:

Sahalie Software
3320 Harris Street
Eugene, OR    97405

The license fee for Message Pad is based on the number of users, as follows:

2 users $30.00
5 users $60.00
10 user $100.00

For more than 10 users, the license fee is $45 per every 5 users.    For licenses exceeding 
25 users, please E-Mail a request for a corporate fee schedule to CompuServe ID 
73617,323 or to America Online Screen Name Sahalie.

CREDIT CARD ORDERS can be placed through the Public Software Library by calling 800-
2424-PSL or 713-524-6398 or by CIS EMail to 71355,470.    THESE NUMBERS ARE FOR 
ORDERS ONLY.    Any questions about the status of the shipment of the order, refunds, 
registration options, product details, technical support, volume discounts, dealer pricing, 
site licences, etc must be directed to Sahalie Software at the address listed above or by CIS
EMail to 73617,323.

5 User and 10 User Licenses for Message Pad can also be ordered through CompuServe's 
Software Registration Database (GO SWREG).        5 User License - ID 1541, 10 User License 
- ID 1544.

Registered users recieve a non-shareware version on disk, a printed manual and a license 
number.    The license number can be used to remove the "Evaluation Copy" flag from the 
main Message Pad window should you obtain a maintenance upgrade from Compuserve or 
America Online (select "Enter License" from the "Help" menu).    Registered Users are 
entitled to free upgrades for one year following registration.

Many thanks to those who have supported Message Pad by registering!    There    is no 
upgrade fee for Version 3.0.      Licensed users of previous versions can use their current 
serial number to remove the "Evaluation Copy" flag.    In addition, all registered users will 
receive by mail a disk and manual for version 3.0, which includes the additional files 
required for Caller Search.

© 1992, 1993 Brian D. Stine.    All rights reserved.



Notification of New Messages
Message Pad checks your Mail account for new phone messages at the time interval 
specified in the Preferences Dialog.    If    a new message is received while Message Pad is
minimized, a dialog box pops up over your current application to notify you that you have 
received a new message. 

If Microsoft Mail is running, but Message Pad is not, you will be notified by a popup dialog 
box when new phone messages are received by MS Mail.

When minimized, Message Pad's icon also acts as a persistent reminder of new messages:

If there are any unread phone messages in your Inbox, Message Pad's icon will display an 
arm holding a telephone.    

If there are no unread phone messages, Message Pad's icon will display a telephone with a 
message pad next to it.



MAPI Session / Re-Login to Mail Server
Message Pad uses MAPI message services.    If another MAPI application, e.g. MS Mail or 
Schedule+,    is already running when Message Pad is started, it will log in to the existing 
MAPI session.    If another MAPI session is not already running, Message Pad will begin a 
new one and will require you to log-in with your user account name and password.

In previous versions of Message Pad, a Mailbox icon with the title "MS Mail Spooler (auto)" 
appeared at the bottom of your screen if Message Pad started a new MAPI session.    This is 
no longer true for Message Pad 3.0.    Now, the icon displays momentarily when a new MAPI 
session is initiated, and then the icon disappears.

If for some reason the MAPI session becomes disconnected, you can Re-Login by selecting 
"Re-Login to Mail Server" from the Options menu.    If you are still unable to reconnect to the
network post-office, close all MAPI applications and re-start them.



Technical Support

Technical support is provided via CompuServe, America Online or Internet E-Mail.    
Questions should be sent to CompuServe ID No. 73617,323 or to America Online Screen 
Name Sahalie or via Internet to bstine@cie-2.uoregon.edu.    Questions will usually be 
answered on the same day theyre posted.



Phone Dialer
If you have a modem with a phone connected to it, Message Pad will automatically dial the 
callers number for you.    

To dial a phone number, click the telephone button or select "Dialer" from the Options 
menu.    You can set the Com port and modem dial strings by selecting "Setup" from the 
Dialer dialog box.



Saving Messages

To save changes to a message select "Save Message" from the File menu or click the 
"Save" button.    This menu item is enabled only when a message is selected in the 
"Pending Messages" listbox.      



Verifying Mailbox Names
When you send a message, Message Pad automatically verifies the recipients mailbox 
name.    If the name does not match a valid user account, the message will not be sent.    If 
you entered a partial name, for instance a first name only, and the name matches more 
than one user account, you are presented with a list of matching names to choose from.

If you are unsure of the correct    name you can type the first few characters of the users 
name and click the checkmark button next to the "To" box.    Message Pad fills in the rest of 
the name if it is valid or lets you select from among any matching names.



Caller Search
Caller Search uses a database of previous callers to help you fill in the name, company and 
phone number of callers.    Caller Search is activated when you click the Compose button 
(or press CTL-N), and it searches for matches as you type in the callers name.    When the 
message is sent, Caller Search automatically updates its database.    Multiple users can 
share the same Caller Search database.

Caller Search is only available in the registered version of Message Pad.

Caller Search uses the Access 1.1 data engine and requires the following dynamic link 
libraries, which are provided in the registered version of Message Pad:    MSAJT110.DLL, 
MSAES110.DLL and VBDB300.DLL.



Recording Follow-Up Activities
To record Follow-Up actions

Display the message

Select the appropriate check marks under the "Follow-Up" heading, e.g. Returned 
Call, Left Message, etc.
The message is automatically saved whenever a Follow-Up checkmark is selected or 
unselected.



New Features in Message Pad 3.0

Recipient Lookup and Pick List

Phone Messages in MS Mail foldersCan be Displayed in Message Pad

Logging of Outgoing and Incoming Messages to comma delimited text files

Message Forwarding improvements

Follow-Up Checkboxes for better message management

Message Pads icon changes to notify of unread messages

Caller Search - available in Registered Version



Starting Message Pad
You can start Message Pad from Program Manager by double clicking the Message Pad icon.

You can also start Message Pad from Microsoft Mail.    There are two ways to start Message 
Pad from Microsoft Mail:

Select "Message Pad" from the Mail menu in MS Mail.

This will start Message Pad or activate the current session if it is already running.    This 
menu item is added to MS Mail by Message Pads Setup program.    If MS Mail was running 
when Message Pad was installed, you need to quit MS Mail and restart it in order for this 
change to take effect.

Open a Message Pad message from Mails InBox or any other Mail folder.

Message Pad messages can be identified in the InBox or other Mail folders by the word 
"PHONE:" at the beginning of the subject line.    By default, Message Pad messages that are 
opened from Mail will be displayed in Message Pad.    This can by changed by selecting 
"Preferences" from the Option menu and unchecking the check box labeled:    "Launch 
Message Pad when message opened in Mail."



Message Logging
Message Pad automatically logs all incoming and outgoing messages to comma delimited 
text files.    By default, outgoing messages are logged to "MSGPAD.LOG" and messages you 
receive are logged to "RCVD.LOG"; both files are initially placed in the Message Pad 
directory.    

You can disable message logging or change the name and directory of the message log 
files by selecting "Message Logs..." from the Options menu.

Messages that you receive are logged when the message is deleted so that any changes 
you make to the mesage and any recorded follow-up activities are included in the log.    
Note that the message must be deleted by Message Pad and not by MS Mail in order for the
message to be added to the log file.

Messages are saved in comma delimited text files because this is a widely recognized 
format that is supported by most word processors, spreadsheet programs and database 
programs.



German Language Version
We are working on a German language version of Message Pad 3.0    If you are interested in 
obtaining more information about this version, please send a message to CompuServe ID 
73617,323 or to America Online Screen Name Sahalie or via the Internet to bstine@cie-
2.uoregon.edu.



 -      Checkmark Button



 -      Rolodex Button



 -      Telephone Button



 -    Unread Messages



 -    Read Messages



 -    Urgent Messages



Messages in Mail Folders
Message Pad messages appear in MS Mail's Inbox and can be opened directly from MS Mail. 
By default, Message Pad messages that are opened from Mail will be displayed in Message 
Pad.    However, Message Pad messages can also be displayed in Mail, like regular Mail 
messages.    This setting is changed from the preferences dialog.

At times, Message Pad messages are also placed in other Mail folders.    For instance, in MS 
Mail you can choose to save copies of all deleted messages to a Deleted Mail folder.    If you
have selected this option, Message Pad messages that are deleted from Mail will also be 
copied to the Delted Mail folder.    You may also choose to manually move or copy Message 
Pad messages to other Mail folders for archiving or message managment.

Messages that have been moved to other folders do not appear in Message Pad's pending 
messages listbox.    You may, however, view those messages in Message Pad by opening 
them from Mail.






